Skip to content

Aperture Compatibility Checker

February 12, 2008

Along with Aperture 2, Apple also releases Aperture Compatibility Checker. The apps will check if your system and graphic cards meet the minimum requirements for Aperture 2. Download it here.

Aperture Compatibility Checker

Aperture Checker

Minimum System Requirements

One of the following Mac computers:

  • Mac Pro
  • MacBook Pro
  • MacBook Air
  • MacBook
  • Mac mini with an Intel Core Solo or Duo processor
  • iMac with a 1.8GHz or faster PowerPC G5 or Intel Core Duo processor
  • Power Mac G5 with a 1.6GHz or faster PowerPC G5 processor
  • 15- or 17-inch PowerBook G4 with a 1.25GHz or faster PowerPC G4 processor

Memory requirements

  • 1GB of RAM
  • 2GB of RAM for Mac Pro

One of the following graphics cards:

  • ATI Radeon X600 Pro, X600 XT, X800 XT Mac Edition, X850 XT, X1600, X1900 XT, 9800 XT, 9800 Pro, 9700 Pro, 9600, 9600 XT, 9600 Pro, 9650, HD 2400 XT, HD 2600 PRO, or HD 2600 XT
  • ATI Mobility Radeon 9700 or 9600
  • ATI Mobility Radeon X1600
  • NVIDIA GeForce FX 5200 Ultra, 6600, 6600 LE, 6800 Ultra DDL, 6800 GT DDL, 7300 GT, 7800 GT, 8600M GT, or 8800 GT
  • NVIDIA Quadro FX 4500 or FX 5600
  • Intel GMA 950 or GMA X3100

Minimum operating system requirements

  • Mac OS X v10.4.11 Tiger
  • Mac OS X v10.5.2 Leopard

DVD drive for installation

5GB of hard drive space for the application and sample projects

No comments yet

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: